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1.1 General 

The Beilstein Commander provides the user interface suite for Beilstein's 
products. The current version supports access to the CrossFire system as well as 
to AutoNom. 

  CrossFire:  
CrossFire is a client-server based database system, which lets you search and 
display information in a way which is most applicable to you; the artificially created 
barriers of information about Substances (molecules and properties), Reactions 
and Citations have been broken. 

  Autonom: 

AutoNom (Automatic Nomenclature) is a fully automatic and practical 
computerized system for the generation of IUPAC systematic nomenclature 
directly from the structure diagrams of organic compounds.  
 
Since the different products have different interface requirements, the 
Commander configures itself accordingly.  

When using CrossFire, the Commander is configured with a Structure and 
Reaction editor, a Fact editor and the Display Hits module. These are all linked 
together through the Commander to give one coherent interface unit. 

The Commander provides the means to access the CrossFire server, Beilstein 
and Gmelin databases and your own customer databases; allowing searches to 
be carried out, results displayed and the database to be browsed - thus giving you 
the ability to navigate through the world of chemistry. 
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1.2 Manuals 
The manuals of the CrossFire package are delivered as a hard copy and as the 
original Microsoft Word for Windows files. You will find the files on CD-ROM.  

 



 

 

Starting the Beilstein Commander 
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2 Starting the Beilstein Commander 
 

After a successful installation, you can start the Commander by double-clicking  

the     icon in the Program Manger. 
  
 

After the Beilstein Commander has been started it will present to you a screen 
with buttons and windows:  

 

 

2.1.1 Starting CrossFire 
Select from the menu Application: CrossFire or click the  - button. Please 
follow the instructions in section 2.2.1 
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2.1.2 Starting Autonom 

Select from the menu Application: AutoNom or click the -button. The 
Commander configures itself in the following way: 

 
Please see further description in section 7. 
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2.2 Starting CrossFire 

2.2.1 Connections Settings 
If no communication profile has been created yet (e.g. by your system 
administrator), you will get the following dialog box:  

 

Click the ‘New’-button and you will get the following dialog box:  

 

 

• Enter the host name 
(name or IP address) 
of your CrossFire 
server. 

• Enter the operating 
system (OS) 

• Click ‘OK’ 

 

 
 

• You are requested to enter a file name, in order to save the settings. 

• Select the profile name *.prf. 
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After the first start of CrossFire you have to enter your Group Name and a Client 
Name. 

 

If you do not know your Group Name, please ask your system administrator. The 
Client Name should be a unique name for your PC. 

 

Click on the   -button and you will get a further dialog box : 

 

Please enter your User ID and password. (If you do not know it, please ask your 
system administrator.) 

 

2.2.2 Select a Database 

Database Selection Bar 
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After a connection to a CrossFire server has been established, the „Database 
Selection Bar “ will display the available databases: 

 
The look of this bar depends on the licensed databases. Beilstein and Gmelin 
databases will be displayed in different list boxes. Every list box will display the 
different database versions. From within this listbox you can select a database. 
You can switch between Beilstein and Gmelin databases listbox on the spot. 

 

 Database: BS = Beilstein (organic chemistry) 
  GM = Gmelin (inorganic chemistry + 
          organometallic chemistry) 
 
    BS0002AE Specification: PR = Plus Reactions 
  AB = PR and Abstracts 
  AE = AB and EcoPharm 
 
 Year and Update Number 
 

2.2.3 Searching Procedure 
• After drawing a query in the Structure Editor (chapter 3) and/ or entering a 

factual query in the EDS form (chapter 4) or Fact Editor (chapter 5), you are 
ready to perform a search in the specified database. 

• Starting a search is only possible from the Commander ! 

• From Structure Editor or Display Hits, switch to the Commander using the -
button or the ‘F7‘-key. 

• To start a search within the Commander simply click the -button or 
use the ‘F7’-key. 

2.2.4 Opening the Structure Editor 

You may use either the Beilstein Structure editor or ISIS/Draw for drawing 
structures and reactions. 

Please use the menu item Options: Structure Editors… for selection. 
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For starting the structure editor:  

• Choose from the menu ’Task:  Structure Editor   or  
• ‘Double click’ on the Structure Editor window   or 
• Click the button   (Structure Editor) 

 
See further description of the Beilstein structure editor in chapter 3. 

2.2.5 Opening an ‘Easy Data Search’ -Form 
The following window makes a list of EDS forms available to you. In order to 
facilitate property searching some predefined EDS-forms are offered.  

The availability of the EDS-forms depends on the kind of the available databases. 
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Select the desired EDS-form. Double click will open the form.  

(See further description in chapter 4). 

 

 

2.2.6 Opening the Fact Editor (Table) 

The Tabular Form 

The tabular form of the Fact Editor allows a guided and flexible, comfortable and 
quick input of all kind of factual queries.  

Please select the top entry „Fact Editor (Table)“ in the EDS-window first.  

• ‘Double click’ on the entry „Fact Editor (Table)“ in the EDS-window    or 

• Double click on the Fact Editor window    or 

• Choose from the menu Task:  Fact Editor or EDS Form  (same as ‘F8‘-key) 
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Beilstein Structure Editor 
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3 Beilstein Structure Editor 
The structure editor allows the input of structure queries as well as reaction 
queries. 

 

Menu

Function Bar

Standard Bar

T
o
o
l
b
o
x

Drawing Window

 

 

The actual Function Bar depends on the selected Editmode. In the Structure 
Editmode ( ) you have typical atom-, bond- and template-buttons. In the 
Reaction Editmode ( ) you have buttons to define a molecule role in a reaction. 

The Standard Bar contains several buttons which provide short-cuts to menu-
functions, including selecting the Editmode and switching to the Beilstein 
Commander. 

 

Toolbox Keys:   

  edit 

  select    

  lasso     

  erase 

  rotate  

  magnify  

  reduce 
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3.1 Drawing / Editing Atoms 

• Activate the edit tool  and choose one of the atom buttons (Function Bar) 

• Draw the structure with the currently active atom and bond (usually the carbon 
skeleton) 

• Click on an already existing atom to open the ‘Atom Attributes’ dialog box to 
change it (editmode) 

• ’Shift+click’ to change an atom to the current selected atom attribute and type  

Atom buttons  

Further choice of atoms as well as generic groups: 
 

 

• Atoms:  
H, F, Cl, Br 

• Atom lists:  
A (any atom), M (any metal), X (any halogen) 

• User Defined  
Apply user defined settings from the ‘Atom Attributes’ dialog 
box  (see 3.6, p. 29)  

• Elements...:   
Opens periodic table from which you can choose  any atom 

• Generics...:  
Opens table of generics from which you can choose 
predefined atom lists, predefined generic groups, user-defined 
atom lists Ax and user-defined generic groups Gx (see 3.9 and 
3.10) 
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3.2 Drawing / Editing Bonds 

• Activate the edit tool  and choose one of the bond buttons 

• Draw the structure with the currently active bond (and atom) 

• Click on an already existing bond to open the ‘Bond Attributes’ dialog box to 
change it (editmode) or ‘shift+click’ to change a bond to the current selected 
bond attribute and type. 
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Bond buttons:   single, double, triple  

Further choice of bonds: 

 

 

• Drawing steric bonds (up , down ) for stereogenic 
atoms 

• Defining Z/E-isomers (double steric ) for double bonds 

• Allowing groups of bonds (any , double/triple , steric 
unknown ) 

• Selecting user-defined bonds 

 

 

! Stereo information is only included in the search when the 'Structure 
Query Options' (see section 3.7) have been set to Absolute, Relative, or 
Racemic. The default setting is 'stereo off'! 
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3.3 Drawing Rings 
Clicking one of the -buttons pastes the corresponding ring into the 
structure window 

 

 

Annelated rings: drag the square in the middle of the bond to the 
bond you want to fuse 

Spiro-fused compounds: drag the square at the atom to merge it to 
another atom 
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3.4 Template Files 

Template files contain pre-defined molecules, substructures as well as functional 
groups 

• Use the template button  to browse the active template file and select the 
desired (sub)structure by ‘double click’ 

• To change the active template file use the menu ‘File: Open’ in the template 
window or choose ‘File: Template’ in the structure editor menu 

• To generate your own template files use the menu ‘File: Save Copy As’ 
Select the position (INO) within the template file with the  -button. 
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3.5 Functional Groups 

Make sure you follow the structure conventions used in the Beilstein database 
(see online help of the Beilstein structure editor); if you are not certain how to draw 
a functional group choose it from the template file "residue.bsd". 

A typical pitfall:  

 
 

"  If different representations are possible, the neutral structure is preferred. 
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3.6 Setting Atom Attributes (individual attributes) 
 

 

Click an atom in the structure editmode ( / ) to 
specify atom attributes: 

• You can enter a number of ‘Free Sites’ (use down 
arrow for MAX), the charge etc. for the selected 
atom 

• Specify isotopes using the ‘Mass’ of the atom 

• Specify the ‘Topology’ (e.g. use ring if you want 
the atom to be part of a ring system) 

• ‘Exclude atoms’ which should not be retrieved in 
the hitset 

 
# If you want to change several atoms in the same manner, check “Set to 

Current”, click “OK” and use “shift+click” to place the current atom at 
additional sites. 
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3.7 Structure Query Options (global attributes) 
Options that will be taken into account for the whole structure query can be set  

• in the Structure Editor from the menu ‘Query’ or  

• in the Commander by opening the dialog box with the ‘Options’-button (hereby 
you can use those options for drawings imported from other structure editors 
such as ISIS) 

 

• Check ‘Implicit Free Sites’ if you 
want to perform a unspecified 
substructure search 

• If you are interested in 
stereochemistry use the appropriate 
switch (i.e. ‘Absolute’ if you are 
searching for exactly the drawn 
stereochemistry) 

Note: Click the button ‘Extended 
Options’ to get a new dialog box, in 
which you can specify the number 
range of charges, unpaired electrons, 
components etc. 

 
• You can also allow or exclude charged or multifragment compounds, isotopes, 

radicals, tautomers etc. 
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3.8 Generic Groups and Atom Lists 
The predefined generics allow you to enter groups of atoms (Predefined Atom 
Lists) or structural elements with certain basic tautologic features (Predefined 
Generic Groups) without the need to specify them completely. 

 

To enter an atom list or a generic group 
you can: 
 

• choose from the atom box  : 
‘Generics’ , select the desired atom list 
or group and place it in the structure 
you are drawing  or 

• click an atom in the editmode ( ) and 
select ‘Symbol; Generics’ in the Atom 
Attributes dialog (see 3.6, p. 29) 

  

!!!! To see the definitions of the predefined generic groups look at the tool tip or 
use the help button to view the hierarchical order  

!!!! The predefined generic groups except G and G* can only have one bond to the 
parent structure. User-defined generic groups and atom lists can have more 
than one bond. 
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3.9 Creating User-defined Generic Groups 

1. Place the Gn-atom symbol ( ) as shown in the previous section in the 
structure you are drawing 

2. Draw the desired fragments for the generic group 

3. Select the fragments to be part of the generic group and press the -button; 
choose the same number as in step 1 

 

 

For fragments containing more than one 
atom you have to set attachment points:

1. Click the atom of the fragment where 
it is to be attached to the parent 
structure  

2. Press the ‘Attachments’-button in the 
atom dialog box 

3. Click the appropriate number(s) 

 

!!!!You can define a frequency for any generic group via the menu ‘Query; Generic 
Frequency’ ; this feature allows you to restrict the occurrences of generic groups 
at the defined positions (e.g. group 1 may occur up to two times at 3 possible 
positions) 
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3.10 Creating User-defined Atom Lists 

1. Choose 'Generics' from the atom menu  and select a number  

     

2. Place the An-atom symbol in the structure you are drawing using ‘Shift+click’ 

3. Press the -button and select the number of the atom group 

4. Choose the desired atoms from the periodic table appearing on the screen 
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3.11 Reaction Attributes 

First draw the molecules in the structure editmode, then switch to reaction 
editmode by using the -button or choose from the menu ‘Editmode: Reaction’. 

 

 

 

The function bar changes to allow reaction role setting and the selectmode is 
activated. Now select a molecule and press the  /  -buttons to 
define its role as starting material or product. 

• You can define one or more 
reactants and one or more 
products 

• You can also define only 
reactant(s) or product(s), so-
called "half-reactions" 
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3.12 Further Reaction Attributes (optional) 
In the reaction editmode the function of the –button is altered. If you click on an 
atom you get the ‘Atom Attributes in Reaction’ dialog box; if you click on a bond 
you enter the ‘Bond Change by Reaction’ dialog. 

 

 

Mapping:  links corresponding atoms in the reactant(s) and product(s) 
respectively by drawing a dashed line between them in the same 
way a chemical bond usually is drawn 

Reaction center:  defines that a reaction must take place (or must not take place) 
at a particular atom 

Bond change



 

 36

3.13 Special Hot Keys (Structure Editor) 

‘Ctrl + D’ Delete all ‘N’ reset average bond length to 
standard 

‘Ctrl + E’ Copy all ‘F’ fit structure into whole window 



 

 

Easy Data Search (EDS) - Form 
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4 Easy Data Search (EDS) Forms 
 

There is a list of predefined EDS-Forms available. The list of EDS-Forms depends 
on the selected database. There are specific Beilstein EDS Forms and Gmelin 
EDS Forms, well adapted for the convenient search in these databases. 

Some examples are described in the following sections. 
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4.1 Identification Data (for the Beilstein Database) 
 

The EDS-form ‘Identification Data’ for the Beilstein database looks like: 

 
In the case of numeric fields (e.g. number of fragments) there is the option to use 
the following operators:   “=”   “<”   “<=”   “>”   or   “>=”. 

• Fill in the search term you are looking for, e.g. chemical name = nifedipine 
• Press the   -button and you will see a list of field values (index of all entries 

in this field). 
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• Select a data entry and click ‘OK’. 

• Click ‘OK’ again and you will get back to the Commander. 

• Start the Search by clicking the   -button or ‘F7’ key. 
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4.2 Bibliographic Data 
 

This form allows to search for authors, journal titles and publication year.  

In addition there is the search field ‘basic index search’, which allows searching 
the abstracts including titles and keywords. 

 
• Looking for an author: If you enter only the last name of the author, you should 

select the option „starts with“. 
• The feature „Basic Index Search“ is only available, if CrossFire Abstracts or 

CrossFire EcoPharm is licensed. 
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5 Tabular Query Editor 
The Tabular Query or Fact Editor allows you to search for properties of 
substances or reactions or for bibliographic information. You can perform factual 
queries either directly in the Fact Editor window (experts) or in the Tabular Query 
Editor (see below). 
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5.1 Field Name  
Fill in the code of the field you want to search for: 

• Type the codes directly into the field   or 

• Pick them from the data structure, which can be opened by the -button, 
double-clicking the cell or ‘F2’-key. Select the appropriate field code by ‘double 
click’ in the ‘Available Fields’ dialog box. 

• You can search for a specific field name by using the ‘Find’-button and typing 
the name of the desired property or attribute in the ‘Available Fields’ dialog box 
(‘F2’-key). 
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5.2 Field Value  
Fill in the search term(s) (e.g. values, keywords, phrases) you are looking for: 

 

• You can fill in ranges using a dash ("-
") or use "<" and ">"-operators when 
looking for numerical values 

• You can use truncation when you 
look for text ("*" for any number of 
letters, "?" for exactly one letter); you 
can truncate at the beginning, middle 
or end of the word  

 

 
You can see a list of field values (index of all entries in this field) by the  -button 
or ‘F2’-key 
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5.3 Operators 
Use the logical operators proximity, and, not, or, near, next to combine fact 
queries (hierarchy: proximity > and, not > or): 

 

• Proximity requires that the search 
terms have to appear in the same 
subrecord and belong to the same 
occurrence of the fact (in this 
example boiling points measured at 
760 Torr). 

• If you want to combine fact queries in 
a different order than the default 
order, use parentheses  or type 
a "+" in front of the operator in the 
fact editor table.  
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5.4 Special Hot Keys (Fact Editor) 
The ‘Selection Area’ list box determines the working area of most functions in the 
Tabular Query Editor. Possible Selections are the whole query, a single line or 
only the marked text. 

  

‘Ctrl + X’    CUT selection 

‘Ctrl + C’    COPY selection 

‘Ctrl + V’    PASTE selection 

‘Ctrl + D’     DELETE Selection 

‘Ctrl + Z’    UNDO 

 

!!!! If you use the "expand"-function by double clicking the field, clicking the -
button or the ‘F2’-key, make sure the cursor is placed in the field you want to 
expand 

!!!! The ‘F3’-key opens a window where you can type in the query  

 



 

 

Display Hit 
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6 Display Hits 
After performing a search you will get a message indicating how many hits are in 
your hit set. To open the ‘Display Hits’-Window click the -button. 

 

! ! ! ! You can customise the way hits are displayed via the 'View' menu (6.3, p.56), 
the 'Options' menu (6.4, p.61) and the Function Bar! 
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6.1 Browsing the Hitset 
 

Hot Key Button Menu ‘Edit: Goto Hit’ 

‘Ctrl + Home’    First Hit 

‘Ctrl + PgUp’    Previous Hit 

‘Ctrl + PgDown’    Next Hit 

‘Ctrl + End’     Last Hit 

‘Alt + S’    Select Hit Number 

 

!!!! You can select and copy both structures and facts from the Display Hits 
Window and paste them into the Structure or Fact Editor where you can 
change and modify them to submit a new query. You can also paste it into any 
other application. 
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6.2 The File Menu 

 

Open Hitset:  
A hitset is loaded from the server side. 

Close Hitset:  
The current hitset will be closed. 

Save Hitset as:   
The current hitset will be saved on the 
server side. 

Delete Hitset:   
Deletes a saved hitset from the server side. 

View Communication:   
A separate window shows the 
communication with the server (former 
application: CrossLink) 

 

Select Registry Number:   
Entering a registry number retrieves the appropriate substance, reaction or 
citation 

Get All References for a Hit:   
Retrieves a list of references for a given substance or reaction (same as CIT-
button). 

Get Citation from LitLink:   
A selected citation is send to the LitLink server. 

Export:   
Exports data from the current hit or hitset. (See following section). 

Print:  
You can print the current hit, a range of hits or the complete hitset. 
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6.2.1 The Export Function  

The menu item File > Export opens the following Export Dialog Box: 

 
This dialog box is divided into two areas: “Export range” and “Export settings”.  

 

• Export range 

Within this area you can decide whether you would like to export “All“ hits, the 
“Current“ hit, “Selected Hits Only" or a "Range“ of hits from a given hitset.  

• Export settings 

The “Export Settings” window presents you all known export settings files for a 
given database. You can select various export settings files, which you can define 
by yourself, or create new ones. Once a settings file has been selected a click on 
“Start export” will perform the export.  

Click the ‘New‘-Button to define new export settings. The Export Wizard starts: 
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Export Wizard 

The Export Wizard is a combination of five dialog boxes which will be presented 
one after the other and which will guide you in a logical order through the process 
of defining export settings.  

The five steps for defining export settings are: 

1. Start:  
this is the first of the export wizards dialog boxes in which it is possible to 
enter a short description of the export settings to be defined. 

2. Define Format :  
here it is possible to define the export target format and the target itself.  

3. Define Data :  
define here the “Export View”, i.e. which data Display Hits should export. If 
“ASCII” has been selected in step 2. then “Structures” will be grayed out. 

4. Define Commands :  
in this dialog box you can define whether you want to execute a command 
after the export has been performed. It is also possible to force Display Hits 
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to show a dialog box, before the actual export starts (default), and to define 
a Task menu item / Task button for the use of the defined export settings. 

5. Finish : 
Before the export settings can be saved this dialog box will display any 
errors and the final settings in an overview. If an error occurs during the 
definition then the ‘Finish’ button will be not available but a ‘Next’ button will 
show up. A click on this button will open the Wizard dialog box in which the 
error was observed. 
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6.3 The View Menu 

 

Short Display ( ):  
toggles between Short- and Full-Display mode. The Short display allows 
several hits within one window for a quick overview (specify the number of rows 
and columns in the ‘Options’ menu). Select individual hits by ‘clicking’ them. 
Double-click to view the full display for a record. 

Identification:  
shows only Identification (IDE)-data of each hit 

All Fields:  
displays all available fields for each hit 

Hit only:  
displays IDE-fields and only the data for the facts that have been searched 

User View:  
shows only those fields that have been selected by the user (customise within 
the menu ‘Options > Define User View…’) 

Field Availability ( ):  
opens an additional window which shows the names and codes of all available 
fields (see section 6.3.1). 
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Hitset Navigator:  
The navigator dialog box allows navigating in hitsets and hyperlinks (see 
section 6.3.2). 

Highlight Hits:  
Highlights the data or (sub)structures that have been searched (the default 
colour is red) 

Include Structures ( ):  
shows the structures associated with the hit in the data display (not 
recommended in the case of large hitsets or slow machines)  

Include Field Availability:  
displays a table of all available fields after the IDE-data for each hit 
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6.3.1 Field Availability Dialog Box 
 

The Field Availability dialog box displays the name of each fact and number of 
occurrences for each fact respectively, thus providing an overview of the 
information present.  

 
 



 

 59

6.3.2 Hitset Navigator Dialog Box 

This is the dialog box for navigating in hitsets and hyperlinks. It will always stay in 
front of the Display Hits until the Close-button has been clicked or the menu item 
View > Hitset Navigator has been unchecked.  

 
The Hitset navigator is divided into a Structure / Query Display Window and a 
Query / Hyperlink Tree. 

• Query / Hyperlink Tree 

This window will display all open windows of the Display Hits (the same list can 
be seen under the Windows menu of the Display Hits, but only as a plain list). It 
usually starts with a hitset identified by its name, typically a Q-number, together 
with a database name. From this every hyperlink will open a new branch.  
A single click on an entry of a branch will update the “Structure / Query Display” 
window. 
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A double click on an entry will update the “Structure / Query Display” window 
and the Display Hits itself and will bring the corresponding hitset/hyperlink 
window to the front. The button “Go To” will do the same. 

• Structure / Query Display window 
This window will always show three pictures. The grey area in the middle 
corresponds to the selected entry in the tree display to the right. If the selected 
entry is a hitset, then it will display the query. If it is a hyperlink then it will 
display the entire structure or reaction. The area on top of the grey area 
displays the structure/reaction of the previous hyperlink. The area below the 
grey area will show the structure/reaction of the following hyperlink. It will only 
display structures or reactions if the hyperlink has been performed manually in 
the Display Hits. 
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6.4 The Options Menu 

You can customise the appearance of the individual applications to a great extent 
using the ‘Options’ menu. In the display hits application you may want to specify 
the display or export layout:  
 

 

Select Colors:  
changes the colours of hyperlinks and highlighting 

Select Short Rows and Columns:  
changes the layout within the short display; up to 15 rows and columns can be 
used independently (this should scale with your screen resolution); in the 
citation context only the definition of rows is utilised (that is, you can only have 
one column). 

Molecule View:  
Specify bond length, atom font etc.… 

Define Export View:  
You can define the extent of information to be extracted. 
!!!!  For defining the specific export format and the destination of the data please 

use the menu item File > Export (section 6.2.1.) 

Define User View:  
Sets a user-defined filter for the display of hits; the fields can be selected and 
combined freely from the data structure of the selected database. Of course 
you can save or load individual user views. 
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!!!!  ‘Define User View’ does not automatically activate it! You can do this in the 
‘View’ menu (see 6.3, p.56) 

Customize Task Menu:   
Within this dialog box you can define tasks, which could be started directly from 
the Display Hits. The defined tasks can be started from the  Task menu or via 
button (T1, T2 etc.).  

Configure Hyperlinks:   
Within this dialog box you may define additional hyperlinks.  

• A hyperlink may start a Commander query. 
• A hyperlink may link to a web page using URL. 
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7 AutoNom 



 

 65

7.1 Starting AutoNom 
AutoNom (Automatic Nomenclature) is a fully automatic and practical 
computerized system for the generation of IUPAC systematic nomenclature 
directly from the structure diagrams of organic compounds.  

• Please start the structure editor (see section 2.2.4) and draw a structure (see 
section 3). 

• Transfer the structure to the Commander using the -button or the ‘F7‘-key. 

• Click the  -button. 

You will get the appropriate IUPAC name. 

Example: 
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7.2 AutoNom 2000: Additional Features 

7.2.1 Show Locants 
Switch on “Show locants“ and you will get the structure display with the 
nomenclature locants. 

 

Example: 

 
 

 

7.2.2 Stereochemistry 
 

Autonom 2000 can process  stereochemical information: 

• Description of the absolute configuration on chirality centers (R,S)  

• Description of the topological stereochemistry on double bonds (E,Z). 
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Example: 

 
 

7.2.3 CAS ring naming convention 

Autonom 2000 supports CAS naming convention in the nomenclature of rings as 
alternative (or addition) to the Beilstein ring system nomenclature. 

Click on the AutoNom Name ‘Options’ button. Select the option: ‘Both’. 

Example: 
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